Discover this year's submissions to the Dataiku Frontrunner Awards and give kudos to your favorite use cases and success stories!READ MORE

Efficientnet in Dataiku

luis_gmc
Level 1
Level 1
Efficientnet in Dataiku

Hello, I am currently working with Computer Vision problems and I need to implement a solution with efficientnet architecture. 

I can see that with the plugins it can not be installed, also I tried to implement it with code but as Dataiku needs a version of TensorFlow below 2.0 and efficientnet is just in versions up to 2.0 I had no luck. 

Has somebody implemented efficientnet in Dataiku? Or somebody knows whether this is possible, and if the answer is yes, can you tell me how could it be? 


Operating system used: Linux Debian

0 Kudos
3 Replies
AlexT
Dataiker
Dataiker

Hi @luis_gmc ,

You should be able to install efficientnet and tensorflow. I had not issues on Python 3.6 managed code env on DSS 9/10.  We did see in the past that you may need to pin tensorflow ==2.1.0 in some cases.

For request packages I have : Screenshot 2022-03-09 at 21.24.23.png

Can you share the exact error you are seeing when trying to install efficientnet?

Thanks

 

0 Kudos
luis_gmc
Level 1
Level 1
Author

Hello, I've tried that and the error that I received is the following: 

 

luis_gmc_0-1646867246522.png

 

I think is due to the combination between keras with keras2

Thanks Alex 

 

0 Kudos
AlexT
Dataiker
Dataiker

@luis_gmc 

In terms of the error reported I see a similar report here :

https://datascience.stackexchange.com/questions/54491/error-input-0-is-incompatible-with-layer-flatt... 

Failed to train : <class 'ValueError'> : Input 0 is incompatible with layer flatten_1:expected min_ndim=3, found ndim=2

Can you check if that solution perhaps works for you? 

Thanks,

0 Kudos