Check out the first Dataiku 8 Deep Dive focusing on Productivity on October 29th Read More

Get Python Interpreter List with DSS Python APIs

Neuron
Neuron
Get Python Interpreter List with DSS Python APIs

Hello!

I was wondering if anyone knows if it is possible to get the list of interpreters for Python that are available to use on the Dataiku instance via the Dataiku Python APIs. I am right now trying to use the APIs to create a code environment and was wondering if there was a way to know what versions of Python are available to select from in order to create a code env. For example, creating with Python 3.6, Python2.7 etc.  


Thank you for your help!

Best, 

Adam

0 Kudos
2 Replies
Dataiker
Dataiker
Hello Adam,
 
DSS is compatible with Python versions 2.7, 3.5 and 3.6. Hence, if they are available at OS level you should be able to use them with code env. Following Linux shell commands should help you find out what version are available on the node:
ls -ls /usr/bin/python* 
whereis python
python3.6 -V 
python3.5 -V
 
Typically (but not necessarily) Python 2.7 will be used as builtin Python environment and an attempt to install Python 3.6 will be performed when installing dependences as part of /scripts/install/install-deps.sh. 
Neuron
Neuron
Author

Thank you for your help!

0 Kudos