Submit your innovative use case or inspiring success story to the 2023 Dataiku Frontrunner Awards! LET'S GO

Regarding the code environment

Solved!
MS_Latha
Level 2
Regarding the code environment

Hi experts,

I am working on developer certification. In the Insights concept, there is a technical requirement to install the following packages 

plotly==4.14.3
nbformat==4.2.0
altair==4.0.1

I am using the online DSS launchpad and created a new code environment with these packages, but I am not able to use it in my insight creation. Help me to resolve this problem.

Thankyou

0 Kudos
1 Solution
AlexT
Dataiker

Hi, 

From the screenshot, it appears you may not be using the dash code enviornment. 
Can you please change the kernel to : 
Screenshot 2022-10-03 at 22.49.44.png

You would then see :

Screenshot 2022-10-03 at 22.51.52.png

View solution in original post

4 Replies
MatiasL
Dataiker

Hello Latha,

If you are using Dataiku Online, you can simply use the “dash” code environment as that one already has those packages installed.

Otherwise, you can follow the instructions in this article to create a code environment compatible with all courses in the Developer learning path.

The tutorial you are following was tested using a Python 3.6 code environment. Other Python versions may be compatible.

Then, within your notebook,  you should import those libraries as you can see while doing the following hands-on: 

https://knowledge.dataiku.com/latest/courses/advanced-code/visualization/static-insights-hands-on.ht...

If you're still not able to do it, could you please let me know if you're actually receiving any type of error?

Hope this information helps and looking forward to your feedback!

 

Best,

Matias

MS_Latha
Level 2
Author

Hi @MatiasL 

Thanks for your response.

As you said the dash code environment has already these packages installed but I am getting the error while executing the code in the notebook. 

Please find the screenshot of the error which is attached.

0 Kudos
AlexT
Dataiker

Hi, 

From the screenshot, it appears you may not be using the dash code enviornment. 
Can you please change the kernel to : 
Screenshot 2022-10-03 at 22.49.44.png

You would then see :

Screenshot 2022-10-03 at 22.51.52.png

MS_Latha
Level 2
Author

@AlexT Thank you so much 🙂

I made the changes as you said, it worked.

0 Kudos