You now have until September 15th to submit your use case or success story to the 2022 Dataiku Frontrunner Awards!ENTER YOUR SUBMISSION

Public WebApp setup

Solved!
tamvap
Level 2
Public WebApp setup

Hello,

I am following the documentation in order to make a webapp Public without any need of authentication.

I have two questions:

  1. After going to settings and use the PROJECTKEY, which extension should I use from these two : "webappid" or "webAppId" ?
  2. When the project key has been added, documentation says to use the below URL:
    http(s)://DSS_BASE_URL/public-webapps/PROJECT_KEY/WEBAPP_ID
     

I am not able to locate "public-webapps" folder inside the DSS.

Additionally, I have the DSS_BASE_URL of my logged on system but then I am not able to put the correct URL on the browser. Can you please let me know with an example what to use for "PROJECT_KEY" and "WEBAPP_ID" of the URL that documentation recommends ?

Thanks,

Panos

0 Kudos
1 Solution
AlexT
Dataiker
Dataiker

Hi,

The WebAppId can be replaced with the actual ID of the webapp. If you open the webapp from the project you wish to make public the information you are looking for will be in the URL you see in the browser :

Screenshot 2021-07-21 at 18.20.47.png

So in my example, I would need to add WEB_APP_UPLOAD.ciRgI9H in the Settings - Public Webapps 

Screenshot 2021-07-21 at 18.17.49.png

 

2. Once added I can access the Webapp via the same URL I use for DSS including port e.g

http://localhost:11200/public-webapps/WEB_APP_UPLOAD/ciRgI9H

You also have the option to add a vanity URL as suggested in the doc if you wish.

 

Let me know if you have any further issues,

 

 

View solution in original post

7 Replies
AlexT
Dataiker
Dataiker

Hi,

The WebAppId can be replaced with the actual ID of the webapp. If you open the webapp from the project you wish to make public the information you are looking for will be in the URL you see in the browser :

Screenshot 2021-07-21 at 18.20.47.png

So in my example, I would need to add WEB_APP_UPLOAD.ciRgI9H in the Settings - Public Webapps 

Screenshot 2021-07-21 at 18.17.49.png

 

2. Once added I can access the Webapp via the same URL I use for DSS including port e.g

http://localhost:11200/public-webapps/WEB_APP_UPLOAD/ciRgI9H

You also have the option to add a vanity URL as suggested in the doc if you wish.

 

Let me know if you have any further issues,

 

 

tamvap
Level 2
Author

Thanks  @AlexT  , it worked fine !

0 Kudos
Snoopy
Dataiker
Dataiker

Hello @AlexT 

I couldn't get vanity URL to work with the below setting though I can access the webapp as a public webapp.

Can you help?

Screenshot 2022-03-11 at 12.39.53 PM.png

0 Kudos
tamvap
Level 2
Author

Hello @Snoopy , 

I haven't define any Vanity URLs in my case. 
Do you need to define it ?

Thanks

0 Kudos
Snoopy
Dataiker
Dataiker

I have not been successful with it and wanted to know if you were able to get it.

0 Kudos
tamvap
Level 2
Author

No I am working with the public URLs without setting up the Vanity URL

0 Kudos
Snoopy
Dataiker
Dataiker

Thanks for getting back @tamvap and @AlexT . I solved it with help of just stopping the backend then restarting 🙂

Screenshot 2022-03-16 at 9.12.03 PM.pngScreenshot 2022-03-16 at 9.11.53 PM.png

0 Kudos