Survey banner
Switching to Dataiku - a new area to help users who are transitioning from other tools and diving into Dataiku! CHECK IT OUT

Missing values

Solved!
Florian__
Level 1
Missing values

Hello everyone,

I try to remplace the missing values by a "prepare" step, I use "add new step"  and impute miising value by mean, after I run and save.

I don't understand why the result can't be seen  in the output.

I try other "add step" like filtre and date ; it works I can see the result in the output.

Thank you for the help

 

0 Kudos
1 Solution
ZachM
Dataiker

Hi @Florian__,

What engine are you using for the Prepare recipe? The "Local stream" engine doesn't support the "Impute with computed value" step, which would explain why the built dataset doesn't contain imputed values.

You can change the engine by selecting the three-gear icon in the bottom left:

07EC1D30-A5B7-43DA-B28A-2D69C95C7F65_1_201_a.jpeg

 

If this doesn't solve your issue, could you please post a screenshot of your Prepare recipe?

Thanks,

Zach

View solution in original post

0 Kudos
2 Replies
ZachM
Dataiker

Hi @Florian__,

What engine are you using for the Prepare recipe? The "Local stream" engine doesn't support the "Impute with computed value" step, which would explain why the built dataset doesn't contain imputed values.

You can change the engine by selecting the three-gear icon in the bottom left:

07EC1D30-A5B7-43DA-B28A-2D69C95C7F65_1_201_a.jpeg

 

If this doesn't solve your issue, could you please post a screenshot of your Prepare recipe?

Thanks,

Zach

0 Kudos
Florian__
Level 1
Author

Thank you very much for your answer.

0 Kudos