Ready for Dataiku 10? Try out the Crash Course on new features!GET STARTED

Error: scenario does not exist: DKU_TUTORIAL_DATAIKU_APPS_yvBotSxy.GENERATEPREDICTIONS

Solved!
Jānis
Level 2
Error: scenario does not exist: DKU_TUTORIAL_DATAIKU_APPS_yvBotSxy.GENERATEPREDICTIONS

Hi,

In the lab "Dataiku Applications Tutorials > Create a Visual Application" I got an error when doing latest Test in Application designer.

pic1.png

 

Where could be the problem?

 

I have made scenarios "Generate predictions"

 

pic2.png

 

and I have set this scenario in the Application designer section Application instance home

 

pic3.png

 

And the same error with the second scenarios and the last Test.

 

pic4.png

0 Kudos
1 Solution
AlexT
Dataiker
Dataiker

I was able to recreate the behavior if the Scenario is created after the Test instance and the actual scenario is created in the test instance instead of the original project. 

 

To resolve this, please

1) Delete your test instance of the application.

Screenshot 2021-11-27 at 10.37.13.pngScreenshot 2021-11-27 at 10.37.21.png

2) To back to the original project and add the scenario there.

2) Go to Application Designer and add the Run scenario tile again.

3) Save and then create the test instance again. 

 

View solution in original post

0 Kudos
3 Replies
AlexT
Dataiker
Dataiker

Hi,

Could you please confirm the exact version of the DSS you are using? 

 

0 Kudos
AlexT
Dataiker
Dataiker

I was able to recreate the behavior if the Scenario is created after the Test instance and the actual scenario is created in the test instance instead of the original project. 

 

To resolve this, please

1) Delete your test instance of the application.

Screenshot 2021-11-27 at 10.37.13.pngScreenshot 2021-11-27 at 10.37.21.png

2) To back to the original project and add the scenario there.

2) Go to Application Designer and add the Run scenario tile again.

3) Save and then create the test instance again. 

 

0 Kudos
Jānis
Level 2
Author

Thank you,@AlexT ! Your solution helped!

 

I just deleted Test instance and generated it again from Application designer.

It looks like it is necessary to delete the test instance, if you add Run scenario Tile and the Test instance is already generated.

0 Kudos