The February release for the Community is live! Read More

An error occurred ERROR: permission denied for schema dku_tshirt Position: 67

Solved!
Herve
Level 3
An error occurred ERROR: permission denied for schema dku_tshirt Position: 67

I get the following 

 An error occurred

ERROR: permission denied for schema dku_tshirt Position: 67

when trying to run 

SELECT campaign, AVG(total), SUM(total), COUNT(campaign)
    FROM "dku_tshirt"."DKU_TUTORIAL_SQL_customers_enriched"
    WHERE birthdate >= '1980-01-01' AND birthdate < '1990-01-01'
    GROUP BY campaign

in the Dataiku DSS & SQL course, section Hands-On: SQL Notebooks

0 Kudos
1 Solution
Herve
Level 3
Author

My bad !!! column was renamed in my dataset, oops 

Using birthdate_parsed works much better

Thanks for the repplies. 

 

View solution in original post

8 Replies
Herve
Level 3
Author

Please note, other SQL Queries run from the DSS recipes work just fine

0 Kudos
Herve
Level 3
Author

Previous step in the section worked too

SELECT * FROM "DKU_TUTORIAL_SQL_customers_enriched"

0 Kudos
tgb417
Neuron
Neuron

@Herve ,

You might try dropping the reference to the schema in your SQL.

SELECT campaign, AVG(total), SUM(total), COUNT(campaign)
    FROM "DKU_TUTORIAL_SQL_customers_enriched"
    WHERE birthdate >= '1980-01-01' AND birthdate < '1990-01-01'
    GROUP BY campaign

Note I dropped:

"dku_tshirt". 

From the query above.

--Tom
0 Kudos
Herve
Level 3
Author

I tried it

SELECT campaign, AVG(total), SUM(total), COUNT(campaign)
FROM "DKU_TUTORIAL_SQL_customers_enriched"
WHERE birthdate >= '1980-01-01' AND birthdate < '1990-01-01'
GROUP BY campaign

gives me another error :

 An error occurred

ERROR: column "birthdate" does not exist Position: 115

0 Kudos
MopeA
Dataiker
Dataiker

Hi, you mentioned that the previous step in the instructions worked when you dropped the reference to the schema:

SELECT * FROM "DKU_TUTORIAL_SQL_customers_enriched"

When you ran this step, were you able to see a preview of the table at the bottom of the code editor? It should show you if the "birthdate" column is in the table. If the column is missing, it might be that you didn't select this column when you used the Join recipe to create the customers_enriched dataset.

Also, you don't have permissions on the "dku_tshirt" schema, probably because you didn't create it. You can follow these instructions from the Integration with SQL databases course to create the schema, and then you should be able to use the code snippets in the tutorial without having to drop the reference to the schema.

Hopefully, this helps. Please let us know. 

Herve
Level 3
Author

When I run 

SELECT * FROM "DKU_TUTORIAL_SQL_customers_enriched"

I get the table 

dss sql.png

0 Kudos
Herve
Level 3
Author

I also did everything listed on https://academy.dataiku.com/integration-with-sql-databases-1/500810 

Wouldn't the "PostgreSQL connection" fail the test otherwise (from DSS settings) ?

0 Kudos
Herve
Level 3
Author

My bad !!! column was renamed in my dataset, oops 

Using birthdate_parsed works much better

Thanks for the repplies. 

 

View solution in original post