DSS Upload CSV File

KAB Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Registered Posts: 4 ✭✭✭✭

Hi Dataikers,

I hope you are well.

I'm a new Dataiku user. I installed DSS 8.0 on my personal laptop with the following characteristics:

  • OS: Windows 10 x64
  • RAM: 16GB
  • CPU:
    Cores: 4
    Logical: 8

I used WSL (Windows Subsystem for Linux) through Linux Ubuntu, therefore, I used an artificial linux terminal to install DSS 8.0 which is installed correctly.

I accessed to the Dataiku Homepage through:
I selected the Free version (without License).

Now, I just created a new project and am stuck at the simple first step of loading my small dataset (cf. File attached to this post).

I selected my CSV file to upload (1000 rows) > I clicked on TEST button and I got the message: Did not find any non-empty file (cf. see image attached)

Do you have any alternative/solution or perhaps something badly done ?

Thank you for your help

Best Answers


  • lorenlai
    lorenlai Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Core Concepts, Dataiku DSS Adv Designer, Registered Posts: 1 ✭✭✭

    KAB - Your suggestion is very helpful and has resolved my issue as well. Thank you very much!

  • tgb417
    tgb417 Dataiku DSS Core Designer, Dataiku DSS & SQL, Dataiku DSS ML Practitioner, Dataiku DSS Core Concepts, Neuron 2020, Neuron, Registered, Dataiku Frontrunner Awards 2021 Finalist, Neuron 2021, Neuron 2022, Frontrunner 2022 Finalist, Frontrunner 2022 Winner, Dataiku Frontrunner Awards 2021 Participant, Frontrunner 2022 Participant, Neuron 2023 Posts: 1,595 Neuron

    , @lorenlai
    , @ATsao

    All, thanks for this post.

    With the gentle encouragement of this post, over the weekend I was also able to reproduce the WSL2 -> Ubuntu 18.04 LTE -> DSS 9.0.4 configuration. I was also able to add an installation of PostgreSQL v10 server to WLS2. And add a basic Python Library based code environment. In total the environment consumes 2-4 GB RAM and I don't know how much File Sotrage. And I'm running on a severely underpowered Laptop, so it is not fast. However, it is working. This frankly surprised me a little bit based on the last time I tried to install DSS on a computer that has Windows as the Base OS.

    I also know that the official "supported" method of installing DSS on a Windows-based OS for "Evaluation" and not Production use is through a VM. However, the last time I checked out the VM it had an older version of DSS installed, and an older version of Linux. Has the trial VM been updated? I have not checked it out recently.

    Also in the past, I had Firewall challenges connecting to DSS from a windows browser on say localhost:11000. Or trying to figure out what the local hostname to call the DSS environment. This is one of the things that caused me problems with the original VM attempts in the past. (In fact, I never did figure out how to sort that issue.)

    So, in general, I was surprisingly pleased with the relative simplicity of installing DSS on WSL2. Now, this is not for someone with no Linux or Windows Administrative experience. But, I've gotten further with this approach than any other approach I've tried on Windows.

    Finally, where are we going to run into challenges with WSL2 and DSS?

    Please share your thoughts.

Setup Info
      Help me…