kubectl failed with code=1 out= err=The connection to the server localhost:8080 was refused - did yo

Options
goku
goku Registered Posts: 16
kubectl failed with code=1 errThe connection to the server localhost:8080 was refused - did you specify the right host or port?

while trying to execute a ppython recipe on an eks cluster that has beem already set up.

Answers

  • Alexandru
    Alexandru Dataiker, Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 1,209 Dataiker
    Options

    Hi @goku
    ,

    The error suggest a configuration issue. DSS is not correctly communicating with the Kubernetes cluster.

    Could you please verify that a default cluster is set by going to Settings > Containerized execution > Default cluster or it can be set at the project level by going to Project settings > Cluster selection > Kubernetes cluster selection.

    You can set a Spark config to your recipe from the recipe page's "Advanced" > "Spark config".

    If this doesn't help, please open a support ticket with instance diagnostics so we can further assist.

    Thanks

Setup Info
    Tags
      Help me…