Can't install DSS on OSX 13.0 Ventura

Options
obretenov
obretenov Registered Posts: 1

Getting this error

CleanShot - Google Chrome - Solved Installation  DSS Start failure - Dataiku Community - 2022-11-08 at 11.50.06@2x.png

Install log shows this

CleanShot - Console - install.log - 2022-11-08 at 11.51.00@2x.png

I already tried following this thread https://community.dataiku.com/t5/Setup-Configuration/DSS-fail-to-install-on-Mac-M1/m-p/27516 which lead me to this thread https://community.dataiku.com/t5/Setup-Configuration/DSS-installed-on-Mac-M1/m-p/27513/highlight/true#M2505 and it simply said to use the Launcher from here https://www.dataiku.com/product/get-started/mac/?_gl=1*r9r0tl*_ga*NDgzNzUzMDM4LjE2Njc4NTM2MjQ.*_ga_B3YXRYMY48*MTY2NzkyNjEyMi4yLjEuMTY2NzkyNjYxMi4zNS4wLjA. and that's exactly what I did.

I also followed this thread https://community.dataiku.com/t5/Setup-Configuration/Could-not-identify-OS-distribution/m-p/2301 but it did nothing - the OS is detected, just not supported.

Is there any workaround for this?
If not does Dataiku post an ETA on release for support of OSX 13? I'm evaluating Dataiku for an Enterprise use-case and subscription so this is time-sensitive.


Operating system used: MacOS 13.0 (22A380)

Tagged:

Best Answer

Answers

  • AlexandreV
    AlexandreV Dataiker Posts: 28 Dataiker
    Options

    Hello @obretenov
    ,
    Dataiku DSS does not support OSX 13 yet. We are working on it and a new version should be available soon. We recommend to wait for this version to be released.

    In the meantime, here are some alternatives:
    - Dataiku Online 14 days trial
    - Installing DSS on Linux (VM or server)

  • clundy-seagen
    clundy-seagen Registered Posts: 1
    Options

    I am receiving an error when the installer starts. I drop the package to the App folder on Ventura and get this error

    22-01-07 14:13:17.123 -0800] ERROR: Could not load /Applications/DataScienceStudio.app/Contents/Resources/app.asar/assets/html/splash.html
    Error: ERR_FAILED (-2) loading 'file:///Applications/DataScienceStudio.app/Contents/Resources/app.asar/assets/html/splash.html'
    at rejectAndCleanup (electron/js2c/browser_init.js:213:985)
    at Object.stopLoadingListener (electron/js2c/browser_init.js:213:1360)
    at Object.emit (events.js:315:20)
    at messageBox (electron/js2c/browser_init.js:49:4548)
    at Object.showMessageBox (electron/js2c/browser_init.js:49:5363)
    at MainInstaller.<anonymous> (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/dist/main-process/installers/main.js:635:64)
    at step (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/dist/main-process/installers/main.js:33:23)
    at Object.next (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/dist/main-process/installers/main.js:14:53)
    at /Applications/DataScienceStudio.app/Contents/Resources/app.asar/dist/main-process/installers/main.js:8:71
    at new Promise (<anonymous>)
    2022-11-23 09:55:13.701 -0800] ERROR (RequestError): self signed certificate in certificate chain
    RequestError: self signed certificate in certificate chain
    at ClientRequest.<anonymous> (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/node_modules/got/dist/source/core/index.js:956:111)
    at Object.onceWrapper (events.js:422:26)
    at ClientRequest.emit (events.js:327:22)
    at ClientRequest.origin.emit (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/node_modules/@szmarczak/http-timer/dist/source/index.js:43:20)
    at TLSSocket.socketErrorListener (_http_client.js:469:9)
    at TLSSocket.emit (events.js:315:20)
    at emitErrorNT (internal/streams/destroy.js:106:8)
    at emitErrorCloseNT (internal/streams/destroy.js:74:3)
    at processTicksAndRejections (internal/process/task_queues.js:80:21)
    at TLSSocket.onConnectSecure (_tls_wrap.js:1497:34)
    at TLSSocket.emit (events.js:315:20)
    at TLSSocket._finishInit (_tls_wrap.js:932:8)
    at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:706:12)
  • AlexandreV
    AlexandreV Dataiker Posts: 28 Dataiker
    Options

    Hello @clundy-seagen
    ,

    self signed certificate in certificate chain

    leads me to think that you could have a faulty certificate in you Mac's keychain or a proxy causing this error (this could happen if you have a company provided laptop).

    Could you send us your full logs located in ~/Library/DataScienceStudio/launcher.log?

    Alex

Setup Info
    Tags
      Help me…