Copy a dataset to another subflow does not work

Options
Leonardo
Leonardo Registered Posts: 14 ✭✭✭✭

Dear DSS,

I have an enriched subflow and want to copy a dataset (without its previous dataset components in the flow) to another subflow.

I tried the following: clicked on the dataset, went to "FLOW ACTIONS", then "copy subflow". This created a copy in my original subflow which I renamed, but it was not built. When I tried to do "Build flow outputs reachable from here" it remained non-built, getting the attached error.

Any ideas would be much appreciated!

Leonardo

Best Answer

  • wlukusa
    wlukusa Dataiker Posts: 8 Dataiker
    Answer ✓
    Options

    Hi @Leonardo
    ,

    Looks like your dataset is using the filesystem connection. When using the "Copy subflow" action with filesystem or uploaded datasets, the dataset data is not copied to prevent duplication.

    Depending on your flow and what you want to achieve, some options might be to :

    • reuse the original dataset for your subflow
    • export your original dataset (in the right panel actions) to either a newly created dataset or the one you already copied. export_dataset_action.png

    Hope this helps !

Setup Info
    Tags
      Help me…