DSS not installing on apple M1

Options
gemma
gemma Dataiku DSS Core Designer, Dataiku DSS & SQL, Dataiku DSS Core Concepts, Registered Posts: 3 ✭✭✭

Hi friends, trying to install DSS in the M1 based mac and it does not complain on the OSx 11.5 but later on when precompiling Dataiku Python code. Any idea how to solve this?

[Install] /Applications/DataScienceStudio.app/Contents/Resources/kit/isntaller.sh: line 322:64762 Killed: 9 "$pythonBin" -m compileall -q "$MYDIR"/python

[-]Error precompiling Dataiku Python code (ignored)

[Install] /Applications/DataScienceStudio.app/Contents/Resources/kit/isntaller.sh: line 322:64763 Killed: 9 "$pythonBin" -m compileall -q "$MYDIR"/dku-jupyter

[-]Error precompiling Jupyter Python code (ignored)

...

DSS installer terminated with status 137

DSS installer failed, fatal error

Answers

  • CoreyS
    CoreyS Dataiker Alumni, Dataiku DSS Core Designer, Dataiku DSS Core Concepts, Registered Posts: 1,150 ✭✭✭✭✭✭✭✭✭
    edited 3:21PM
    Options

    Hi @gemma
    and welcome to the Dataiku Community. At this time DSS installation on Apple M1 MacBooks is not supported. We currently do not have an ETA for a compatible release. More information about M1 compatibility with DSS can be found on these threads: DSS fail to install on Mac M1

    If this is the first time you are trying out DSS and would still like to use it, we encourage you to use Dataiku Online with a 14 day free trial.

    This is a known limitation due to python compilation issues (not really DSS but still). Based on the community thread, you can try to workaround this by installing the Rosetta emulator:

    https://support.apple.com/en-us/HT211861

    Also, you can try an option with base Python3.7 for installer.sh:

    <DSS_INSTALL_DIR>/installer.sh -d <DSS_DATA_DIR> -P python3.7

    I hope this helps!

  • gemma
    gemma Dataiku DSS Core Designer, Dataiku DSS & SQL, Dataiku DSS Core Concepts, Registered Posts: 3 ✭✭✭
    edited 3:21PM
    Options

    thanks. I tried different things now without success: (i) I installed Rosetta2 but DataScienceStudio.app does not allow me to open it with Rosetta2 (see screen shot below); (ii) I have also downloaded the tar.jar packages, and run from terminal but I get the following error:

    dataiku % dataiku-dss-9.0.4-osx/installer.sh -d /egemval/dataiku/dss_data -l /egemval/dataiku/license.json -p 10000

    *********************************************

    * Dataiku DSS installer *

    *********************************************

    [+] Creating data directory: /egemval/dataiku/dss_data

    mkdir: /egemval/dataiku/dss_data: Read-only file system

    and it stops here.

    (iii) I also tried to run the

    <DSS_INSTALL_DIR>/installer.sh -d <DSS_DATA_DIR> -P python3.7

    but there is no installer.sh file in the dss_home folder.

    note: I am not a unix expert.

Setup Info
    Tags
      Help me…