Automation node failed connection

JanMigon Registered Posts: 6 ✭✭✭

Hi everyone, I am working for Daimler and we have several dataiku instances that we use. Recently I setup an automation node instance. Our networking infrastructure is quite complicated however I made sure that now I can finally access automation node from the browser with no problems. I can also curl to automation node url from the vm running design node. What is important is that both, design node and automation node, are listening only on port 443 and the requests are redirected to necessary dataiku base port with nginx. However when I was trying to create an infrastructure on the design node with the valid automation node url, I got an error "Failed contacting the automation node: Name or service not known". I cant see any other errors or logs on the vm.
My assumption is that the connection between design node and automation node is established on a specific port hence the error.
Could you tell me whether this is indeed a cause to the above problem and if so, what is the port I should open?

Thanks in advance


  • Alexandru
    Alexandru Dataiker, Dataiku DSS Core Designer, Dataiku DSS ML Practitioner, Dataiku DSS Adv Designer, Registered Posts: 1,209 Dataiker


    The error "Name or service not known" suggests there is either an issue with the URL or that the DNS resolution on the design node which I assume is using the local deployer in your case.

    Can you run the following as the dss user on the design node :

    nslookup automation-node-url

    curl -kv https://automation-node-host.domain-url:443

    Can you try with the URL is in the format https:///automation-node-host.domain:443/

    If DNS resolution is failing you can try using an IP instead of the hostname as a test.

  • JanMigon
    JanMigon Registered Posts: 6 ✭✭✭

    Hi Alex,
    thank you for the quick reply. The problem is resolved now. I was confused because the curl calls from design node vm to automation node dns worked but the connection on dataiku level did not. What I forgot about is that on the vm level I have configured the https_proxy variable ( it was not used by dataiku as I thought) and that is why the curl worked on the vm level only. I did the same for dataiku and it is working now. Thank you for the support!

Setup Info
      Help me…