File general-settings.json does not exist

Options
jazcap53
jazcap53 Registered Posts: 4 ✭✭✭

Hi All,

I've been running Dataiku 8 on my Fedora 33 machine using a CentOS 8 Stream VM created with Boxes.

It's worked well; I've been running the tutorials and trying out the Kaggle Titanic problem.

I downloaded Dataiku 9, and tried installing it in parallel with Dataiku 8. (D8 is in $HOME/dataiku; D9 is in $HOME/dataiku_9). But when I try to run D9 the Server won't start. In the server logs, I see the message:

java.io.FileNotFoundException: File '/home/jazcap53/dataiku_9/data/config/general-settings.json' does not exist.

Does anyone have ideas on how to deal with this problem?

Many thanks in advance for your replies; this forum has been very helpful to me in the past, and I appreciate it.

Best Answer

  • Ignacio_Toledo
    Ignacio_Toledo Dataiku DSS Core Designer, Dataiku DSS Core Concepts, Neuron 2020, Neuron, Registered, Dataiku Frontrunner Awards 2021 Finalist, Neuron 2021, Neuron 2022, Frontrunner 2022 Finalist, Frontrunner 2022 Winner, Dataiku Frontrunner Awards 2021 Participant, Frontrunner 2022 Participant, Neuron 2023 Posts: 411 Neuron
    Answer ✓
    Options

    Hello @jazcap53
    ,

    Since you are saying that the new installation of DSS 9 is at '$HOME/dataiku_9', I wonder where is the 'data' in '/home/jazcap53/dataiku_9/data/config/general-settings.json' coming from. If your DATADIR is '$HOME/dataiku_9' the general-settings.json should be at '/home/jazcap53/dataiku_9/config/general-settings.json'

    That's all I can think of with the information you are providing, a problem with the paths.

Setup Info
    Tags
      Help me…