Discover this year's submissions to the Dataiku Frontrunner Awards and give kudos to your favorite use cases and success stories!READ MORE

pkg_resources.DistributionNotFound: The 'certifi>=2017.4.17' distribution was not found and is requi

kim13
Level 1
pkg_resources.DistributionNotFound: The 'certifi>=2017.4.17' distribution was not found and is requi

Hi All, 

I just click on update the code env without touching anything but it just error. 

How can I fix it please? 😭

Picture1.png

Updating code environment according to spec ...

Installing from Conda spec file

Installing from Conda spec file

Traceback (most recent call last):

  File "/usr/bin/conda", line 6, in <module>

    from pkg_resources import load_entry_point

  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3095, in <module>

    @_call_aside

  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3079, in _call_aside

    f(*args, **kwargs)

  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3108, in _initialize_master_working_set

    working_set = WorkingSet._build_master()

  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 570, in _build_master

    ws.require(__requires__)

  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 888, in require

    needed = self.resolve(parse_requirements(requirements))

  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 774, in resolve

    raise DistributionNotFound(req, requirers)

pkg_resources.DistributionNotFound: The 'certifi>=2017.4.17' distribution was not found and is required by requests

0 Kudos
11 Replies
sergeyd
Dataiker
Dataiker

Hi @kim13 

Cannot say anything at this point (other than the internal issue with conda/python) without full code env diag or at least without full logs, but at this point and considering the other community thread you opened may be the simplest way will be to delete this code env and recreate it. 

0 Kudos
kim13
Level 1
Author

Hi @sergeyd , 

I have tried to create new code env without deleting the DEV code env ( that had issue). 

However I had problem below

pkg_resources.DistributionNotFound: The 'certifi>=2017.4.17' distribution was not found and is required by requests

Is it a must to delete off DEV code env? 

 

0 Kudos
kim13
Level 1
Author

@sergeyd attached the pic 

0 Kudos
sergeyd
Dataiker
Dataiker

Hi, 

This has nothing to do with other code envs or even with DSS at this point.

Basically, your conda setup is broken. You can easily replicate this issue outside of DSS by creating conda env and installing the "requests" package into it. Alternatively, you can try using natively installed python version however I am not sure what distro you are running so it might not be available. 

0 Kudos
kim13
Level 1
Author

Hi  @sergeyd ,

Do you mean that now I can delete the DEV(that had issue) and recreate the same DEV and my notebook would be able to work ? 

 

0 Kudos
sergeyd
Dataiker
Dataiker

Hi,

No, I do expect this will fail as well.

You will need to check your conda setup first. Check if you can create a code env outside of DSS and install pandas, requests package there. 

0 Kudos
kim13
Level 1
Author

Hi @sergeyd , 

Do you think its easier to uninstall dataiku and reinstall back to have a clean start ? 

Do you have any idea how?

DEV23.PNG

0 Kudos
sergeyd
Dataiker
Dataiker

Ok, so you are indeed using the VM provided by us. Reinstalling DSS will not help as the issue with conda. Unless you use a clean VM from scratch. 

I do not understand why you are using conda if there is a natively installed python3.6. Can you try creating code env with unchecking "use conda"? 

0 Kudos
kim13
Level 1
Author

Hi @sergeyd ,

I managed to create a new DEV2 without conda. 

I thought I must have conda when I create code env.  What is it used for ?

Most importantly how do I change the code env for my existing notebook that is currently connected to DEV(the one that fail)? 

 

0 Kudos
sergeyd
Dataiker
Dataiker

Hm...while you were able to create a code env but you were not able to install any packages into it so you will not be able to use it (including in the notebooks). 

This VM image looks broken to me as I cannot reproduce any of the issues reported. Can you download the new one? I would recommend grabbing the latest 10.0.5: 

https://downloads.dataiku.com/public/studio/10.0.5/dataiku-dss-10.0.5.ova

 

0 Kudos
kim13
Level 1
Author

HI @sergeyd ,

In the new DEV2, the jupyter kernel is not installed, does that mean I wont be able to select DEV2 as my kernel ? How to enable it?

0 Kudos