The Dataiku Frontrunner Awards have just launched to recognize your achievements! Submit Your Entry

DSS installed on Mac M1

Antonius
Level 2
DSS installed on Mac M1

I've got DSS running in my Mac mini M1; I hope this helps. My current system:

Mac mini M1 (macOS 11.2.3)
Java version 8 update 281
Python 3.7.9 (to run the installer)
Python 3.6.8 (for some plugins needing v3.6)
DSS 9.0.1

Installed DSS 9.0.1 (dmg file), ran the application and failed. Then I edited the following (after many trials and fatal failures though)...

Show the package contents and go to:
Contents/Resources/kit/installer.sh

I found this line in the file and edited like this:
BASE_PYTHON=/usr/local/bin/python3.7

After that, and following the documentation for Linux (link), and figuring out how to do the same in Mac I opened the Terminal and ran:

export DKUPYTHONBIN=/usr/local/bin/python3.7

I did a test to see if I did it right with:

echo $DKUPYTHONBIN

Ran DSS application and started in a flash . Not sure if one or both helped but I've got DSS running in my Mac mini M1. I am a happy man 🙂. Cheers.

2 Replies
CoreyS
Community Manager
Community Manager

Thanks for sharing your knowledge @Antonius! I went ahead and shared this on the DSS fail to install on Mac M1 thread.

Looking for more resources to help you use DSS effectively and upskill your knowledge? Check out these great resources: Dataiku Academy | Documentation | Knowledge Base

A reply answered your question? Mark as ‘Accepted Solution’ to help others like you!
tgb417
Neuron
Neuron

@Antonius ,

This is really cool.  However, it brings up a bunch of questions for me.

DSS is a really large system.  Can you clarify what all you have gotten working and tested?

Sounds like you have the UI up and running and have been able to log in.  Is that correct?

Are you able to get visual recipes, charting, Visual ML working?

What data sources have you tried?

Have you done any work with any of the plugins?

My guess is that you may have Python Jupiter Notebooks working.  Have you tried R, SQL?

Is this code running natively on ARM or is it running through Rosetta 2? How is the performance?

 

--Tom
0 Kudos