How to make a clean uninstall of DSS on Mac?

Options
UserBird
UserBird Dataiker, Alpha Tester Posts: 535 Dataiker
Hi,

How can I delete Data Science Studio application and all the settings file on Mac OS X?
I want to start with a new fresh install.

Best Answer

  • jereze
    jereze Alpha Tester, Dataiker Alumni Posts: 190 ✭✭✭✭✭✭✭✭
    Answer ✓
    Options

    Hi,

    In a normal installation of Dataiku DSS on Mac OS X, two folders would be used:

      • /Applications/DataScienceStudio.app : it is the Data Science Studio application
      • ~/Library/DataScienceStudio : it is where DSS installs your settings, managed datasets, logs... (read more about the DATADIR)

    Here is the clean uninstall process step-by-step:

      • Make sure that DSS is stopped
      • Open Finder, open the Applications folder.
      • Find DataScienceStudio and delete it.
      • Open Finder again, option-click the Go menu, hold down the Option key (alt key), click on Library.

      • Find DataScienceStudio and delete it.



    To reinstall DSS from scratch, you can now download the DMG file on www.dataiku.com

Answers

  • Orbifold
    Orbifold Registered Posts: 4 ✭✭✭✭
    Options
    FYI: on MacOS Sierra this is now SHIFT instead of Options/ALT.
  • AILearner
    AILearner Registered Posts: 2
    Options

    Hi,

    I followed the instructions here, including deleting both the application (/Applications/DataScienceStudio.app) and the settings (~/Library/DataScienceStudio), then restarted. When I click on the app, I am able to download, extract, but get stuck on "installing."

    The logs show:

    [2024-04-14 15:13:15.363 -0700] ERROR: The Dataiku DSS installer closed with code 1
    Error: The Dataiku DSS installer closed with code 1
    at ChildProcess.<anonymous> (/Applications/DataScienceStudio.app/Contents/Resources/app.asar/src/main-process/installers/dss.ts:99:35)
    at ChildProcess.emit (events.js:315:20)
    at maybeClose (internal/child_process.js:1048:16)
    at Socket.<anonymous> (internal/child_process.js:439:11)
    at Socket.emit (events.js:315:20)
    at Pipe.<anonymous> (net.js:673:12)

    There must be some stray setting somewhere. I've repeated the procedure above but end up with the same error

  • AILearner
    AILearner Registered Posts: 2
    Options

    Updating this on the fix. Tried deleting both files again and restarting. That fixed the issue. I think there were some stray leftover config messing things up

Setup Info
    Tags
      Help me…