Check out the first Dataiku 8 Deep Dive focusing on Productivity on October 29th Read More

SQL database Schema detection

Level 2
SQL database Schema detection

Hello,

I'm struggling to import several SQL tables (about 20) at the same time since I have a PostgreSQL database with different schemas defined inside it. The database contains several tables that can have identical names across the defined schemas. For example: Database / Schema 1 / table 1 ("AAA") ,table 2 ("BBB"). Database / Schema B / table 3 ("AAA"), table 4 ("BBB").

But when I try to import database through Dataiku (see picture below), the schema under which tables are stored is not detected in the field "restrict to schema". Why is that ? How can I allow automatic detection of schemas ? 

It would greatly help to import the right tables from a database schema at once without mixing them since they have the same name.

 
 

Sans titre.png

 

 

4 Replies
Dataiker
Dataiker

Hi,

"Restrict to schema" is if you want to search for tables inside just one schema. In that case, you would need to click on the "refresh" icon next to "Restirct to schema" to actually fetch the list of schemas.

In your case, you actually want to search across all schemas, so you should just click on "List tables". You will receive a list of all tables in your database, across all schemas, and can select all your tables, that will all be imported while remembering from which schema they came from.

0 Kudos
Level 2
Author

Hi,

My goal is actually to search within one schema. Nothing except "any" is displayed when I click on the refresh button. How can I make it work ?

0 Kudos
Dataiker
Dataiker

Hi,

Hard to say. Your database may be rejecting schema listing.  When you select Any and click on List tables, what do you see ? Does this populate the Schema tab then ? Do you see a schema in the listed tables ? What is your database precisely ?

0 Kudos
Level 1

Having the same issue, no matter what I try, setting a "Schema search path", adding "Advanced JDBC properties" or using "Restrict to schema", it never actually works with my PostgreSQL database.

0 Kudos