RMarkdown: pandoc version issue

Highlighted
aad34210
Level 2
RMarkdown: pandoc version issue

Hi, everyone.



I faced error when "FORCE BUILD" button on "Rmarkdown report" clicked.

Error message shows following.



Would you please help me how to solve this issues?

It seems that pandoc need to be update but I couldn't find out how to update pandoc in this environment...

This environment is running on AWS EC2 server (Amazon Linux AMI release 2018.03).





Best regards.

Thank you.

0 Kudos
1 Reply
aad34210
Level 2
Re: RMarkdown: pandoc version issue

I resolved this question myself in following way.

For person who facing same issue I explain how to resolve this issue.



====



Environment: AWS EC2 Amazon Linux 2018.3



1. Install stack (Haskell based) 

    https://docs.haskellstack.org/en/stable/install_and_upgrade/#linux

2.  Download pandoc from source code.

3.  Compiling from pandoc source code.

    https://pandoc.org/installing.html#compiling-from-source



*Note*

Sample code in above documents.

====



Best regards.

Thank you.

0 Kudos
Labels (1)