Meet DSS user Ben Powis, Data Science Manager at UK retail company MandM Direct Read More

Python Package error after setting new environment with required environmet

Level 2
Python Package error after setting new environment with required environmet

I have created  a python environment with python 3.6 from dss managed .

i have given the custom packaged required with the versions mentioned. when i am trying to use that kernel i am facing error with the packages.

 

MicrosoftTeams-image (2).png

 

can someone walk me through this?? @Alex_Combessie  can you 

0 Kudos
2 Replies
Dataiker
Dataiker

Hi,

DSS mandates a version of pandas for its APIs. You need to explicitely specify a version of pandas in your code env's requirements, like pandas==0.23, or remove your existing pandas requirement if you have one. Alternatively, you can upgrade DSS to 8.0.1

0 Kudos
Level 2
Author

Well, I have specified pandas==0.25.1 as it is required package for our code. and that is the reason it was asking i guess. can we install python 3.7 as env in dataiku?

0 Kudos