The Dataiku Frontrunner Awards have launched to recognize your achievements! SUBMIT YOUR ENTRY

Errors when installing Facebook Prophet

Solved!
ben_p
Neuron
Neuron
Errors when installing Facebook Prophet

Hello everyone,

We are trying to install Facebook Prophet onto a python 3.6 code environment but having some issues, adding the package to the install list and apply to the environment returns the following error:

    running install
running build
running build_py
creating build
creating build/lib
creating build/lib/fbprophet
Running setup.py install for fbprophet: finished with status 'error'
creating build/lib/fbprophet/stan_model
INFO:pystan:COMPILING THE C++ CODE FOR MODEL anon_model_dfdaf2b8ece8a02eb11f050ec701c0ec NOW.
error: command 'gcc' failed with exit status 1

We raised this with support (who have been great as always, but I am sharing this publicly to help anyone else who may hit this issue in the future) who said:

"Thank you for that log file. It looks like there is a missing system library that is preventing Pystan from running. Pystan needs the Python Development Headers package in order to run."

And directed us to this link:

https://doc.dataiku.com/dss/latest/code-envs/troubleshooting.html#creation-or-package-installation-f...

Following the info on this page we did a:

yum install python-devel

On our machine, but this appears to have more no difference and the original error persists.

Has anyone seen similar errors before when installing Prophet and were you able to get it in and working?

Best,
Ben

0 Kudos
1 Solution
sergeyd
Dataiker
Dataiker

Hi @ben_p 

I already responded on the support ticket and copying over the response here: 

This error means that the C++ compiler isn't hooked up correctly to PyStan. Looks like you have CentOS/RHEL7 and the reason it isn't working is that CentOS 7 does not support C++14, which is a new requirement for the latest version (2.19+) of PyStan: https://github.com/facebook/prophet/issues/1057
The solution is either to downgrade to PyStan 2.18 or use SCL devtoolset.

For the option of downgrading pystan: In the list of packages please add the next line:
    pystan==2.18.0.0


For the SCL devtoolset option, you need to install and activate the SCL devtoolset package for use by DSS by adding the following line to the DSS_DATADIR/bin/env-site.sh:

    source /opt/rh/devtoolset-8/enable

A restart of DSS is required after doing this.

View solution in original post

2 Replies
sergeyd
Dataiker
Dataiker

Hi @ben_p 

I already responded on the support ticket and copying over the response here: 

This error means that the C++ compiler isn't hooked up correctly to PyStan. Looks like you have CentOS/RHEL7 and the reason it isn't working is that CentOS 7 does not support C++14, which is a new requirement for the latest version (2.19+) of PyStan: https://github.com/facebook/prophet/issues/1057
The solution is either to downgrade to PyStan 2.18 or use SCL devtoolset.

For the option of downgrading pystan: In the list of packages please add the next line:
    pystan==2.18.0.0


For the SCL devtoolset option, you need to install and activate the SCL devtoolset package for use by DSS by adding the following line to the DSS_DATADIR/bin/env-site.sh:

    source /opt/rh/devtoolset-8/enable

A restart of DSS is required after doing this.

View solution in original post

ben_p
Neuron
Neuron
Author

Thanks @sergeyd, that downgrade seems to have done the job!

A banner prompting to get Dataiku DSS
Public