Community Conundrum 28: News Engagement is live! Read More

Errors encountered in setting up API Nodes

Level 2
Level 2
Errors encountered in setting up API Nodes

Hello,

My DSS instance is deployed on a regular GCP compute instance. I was trying to deploy an API for my predictive model, but I kept running into issues with the API nodes in the API Deployer Infrastructures. Is there any documentations on how to properly set up API nodes? 

The error message shows "Expected a com.google.gson.JsonArray but was com.google.gson.JsonPrimitive". Wanted to see if I can get some help with setting up API nodes properly that works with GCP. Thanks!

 

Best,

Mark

0 Kudos
1 Reply
Dataiker
Dataiker

Hi,

First of all, are your API nodes and API deployer running the same version of DSS ? Was the model that you are trying to deploy trained with the same version of DSS ?

If there are no version mismatches, please open a support ticket as described in https://doc.dataiku.com/dss/latest/troubleshooting/obtaining-support.html

In your support ticket, please include:

  • An instance diagnosis of your API deployer node. Go to Administration > Maintenance > Diagnostic tool and send us the resulting file. Note that you need to be administrator of the DSS instance - else you'll need to ask your admin.
     
    If the resulting file is too large for mail (> 15 MB), you can use https://dl.dataiku.com to send it to us. Please don't forget to send the link that is generated when you upload the file.
  • The "run/apimain.log" file from your API node
0 Kudos
A banner prompting to get Dataiku DSS