Community Conundrum 10: The Titanic is now live Learn more

Error in Lime plugin used for Keras models

Level 1
Error in Lime plugin used for Keras models

Hello,



I am trying to use the the lime plugin for a model created by Keras (from dataiku models). It works for regular models (sklearn models), but for the Keras model I receive the following error:



happening at:




python/dataiku/core/saved_model.py


and the error:




f = h5dict(filepath, 'r')
.... python2.7/site-packages/keras/utils/io_utils.py", line 197, in __init__
[14:52:34] [INFO] [dku.utils] - 'Received: {}.'.format(type(path)))
[14:52:34] [INFO] [dku.utils] - TypeError: Required Group, str or dict. Received: <type 'unicode'>.


Any idea why this happens and how to solve it?



 



Thanks

0 Kudos
0 Replies
Labels (2)