Survey banner
The Dataiku Community is moving to a new home! We are temporary in read only mode: LEARN MORE

EKS Cluster creation fails because of tag name format

samwachtel
Level 1
EKS Cluster creation fails because of tag name format

Hey there,

We're using the EKS Plugin v1.4.0 (previously running 1.3.2 with same result) and when we deploy an EKS cluster, we get the below error on the eksctl-clustername-nodegroup-cluster-ng-0 step in CloudFormation.

It seems to be related to the way the tag names are formatted using a forward slash, but looking back on a successful deployment from a few weeks ago (it was working a few weeks ago), the tag is formatted the same way in the template. Any advice would be great, thanks! 

Resource handler returned message: "'alpha.eksctl.io/nodegroup-type' is not a valid tag key. Tag keys must match pattern ([0-9a-zA-Z\\-_+=,.@:]{1,255}), and must not be a reserved name ('.', '..', '_index') (Service: Eks, Status Code: 400, Request ID: xxxxx)" (RequestToken: xxxxx, HandlerErrorCode: InvalidRequest)
DSS version: 12.5.2
OS: almalinux (8.9)
Java: Red Hat, Inc. (1.8.0_402)

Operating system used: almalinux (8.9)


Operating system used: almalinux (8.9)

0 Kudos
1 Reply
AlexT
Dataiker

Hi,
A new verison of the plugin was released, 1.4.1 can you please confirm if you still have the same error with the latest version. Please note you should use Python 3. x code env for the latest version.

If the issues persist, please open a support ticket with the cluster diagnostics so we can review further.

THanks

0 Kudos