You now have until September 15th to submit your use case or success story to the 2022 Dataiku Frontrunner Awards!ENTER YOUR SUBMISSION

SSL Error with Census USA

Solved!
Sv3n-Sk4
Level 2
SSL Error with Census USA

Hello Everyone,

Could someone tell me why I am always getting an error when trying to build the datasets in the diffrent projects for the advanced designer path ?

Almost all projects raise me the error when I am trying to build all existing flow.
Seems to come from CENSUS USA but I didn't get any error when installing the plugin.

 

 Oops: an unexpected error occurred

Error in Python process: At line 107: <class 'requests.exceptions.SSLError'>: [Errno None] None: 'None'

HTTP code: , type: <class 'requests.exceptions.SSLError'>

 

Thanks a lot.


Operating system used: Linux via VMware

0 Kudos
1 Solution
tgb417
Neuron
Neuron

@Sv3n-Sk4 

Welcome to the Datataiku Community.

I've also had problems  with the Census Plugin over the past week or so.

Here is a more detailed thread on the subject.

https://community.dataiku.com/t5/Academy-Discussions/Flow-Views-amp-Automation-Tutorial-fail-on-comp...

I'm re-testing things today.  And I failed again in the same ways I've failed for the past week or so.

--Tom

View solution in original post

3 Replies
sergeyd
Dataiker
Dataiker

Hi @Sv3n-Sk4 

It's challenging to say where precisely this error is shown as we do not have any more details (like a screenshot) and you are saying you are building the entire flow so there can be many recipes involved.  

During plugin installation, only the plugin and code env is installed while running the recipe other resources may be checked/downloaded like: 

https://geocoding.geo.census.gov

https://www2.census.gov

and here is where this requests.exceptions.SSLError: [Errno None] error may appear.

Without job logs, it's difficult to say more but I do suspect that none here is that the connection to the above links cannot be accessed from the DSS host (firewall/proxy?). 

 

tgb417
Neuron
Neuron

@Sv3n-Sk4 

Welcome to the Datataiku Community.

I've also had problems  with the Census Plugin over the past week or so.

Here is a more detailed thread on the subject.

https://community.dataiku.com/t5/Academy-Discussions/Flow-Views-amp-Automation-Tutorial-fail-on-comp...

I'm re-testing things today.  And I failed again in the same ways I've failed for the past week or so.

--Tom
Sv3n-Sk4
Level 2
Author

Thanks both of you for your answer! 

It looks like I am in the same case as you @tgb417  (same errors report and when I tried like 2/3 ago for the first time it was working).

I will wait hoping it's coming back working!

0 Kudos