The February release for the Community is live! Read More

Issue with Plugins of speechtotext

Solved!
BALA
Level 2
Issue with Plugins of speechtotext

Hi , I am trying to use speech to text plugin in my project and I downloaded  deepspeech weight from macro.I have created folder containing audio file but I am getting the issue attached here.Please find let me know possible solutions Thank you !

0 Kudos
1 Solution
Alex_Combessie
Dataiker
Dataiker

Hi,

Thanks for your interest in this plugin.

The latest version of the DeepSpeech model requires a recent version of libstdc++6, as indicated by the error message. To upgrade libstdc++6,  you will need to have admin access to the underlying server hosting DSS. If you have this access, and can confirm which Linux version you are running, I can guide you with these operations.

Alternatively, you can use an older version of the DeepSpeech model using the previous version of this plugin: [EDIT] https://update.dataiku.com/dss/8.0/plugins/speech-to-text-cpu/0.1.0/dss-plugin-speech-to-text-cpu-0....

Note that in that case, you will need to install the plugin manually from the ZIP archive: https://doc.dataiku.com/dss/latest/plugins/installing.html#installing-from-a-zip-file. You will no longer be able to benefit from the latest updates from the Store.

Please let me know which direction you'd like to take, and I'll be able to advise.

Cheers,

Alex

View solution in original post

22 Replies
Alex_Combessie
Dataiker
Dataiker

Hi,

Thanks for your interest in this plugin.

The latest version of the DeepSpeech model requires a recent version of libstdc++6, as indicated by the error message. To upgrade libstdc++6,  you will need to have admin access to the underlying server hosting DSS. If you have this access, and can confirm which Linux version you are running, I can guide you with these operations.

Alternatively, you can use an older version of the DeepSpeech model using the previous version of this plugin: [EDIT] https://update.dataiku.com/dss/8.0/plugins/speech-to-text-cpu/0.1.0/dss-plugin-speech-to-text-cpu-0....

Note that in that case, you will need to install the plugin manually from the ZIP archive: https://doc.dataiku.com/dss/latest/plugins/installing.html#installing-from-a-zip-file. You will no longer be able to benefit from the latest updates from the Store.

Please let me know which direction you'd like to take, and I'll be able to advise.

Cheers,

Alex

View solution in original post

BALA
Level 2
Author

Thank you Alex, I am first wanna try with older version by manual download  of that plugin if again the issue continues let you know!

 

BALA
Level 2
Author

Hi Alex,

I am need your support to extract the zip file. to proceed with your help.I am not able to go with your solution now.Let me know if you are possible with any chat in mail gmeet or any?

 

0 Kudos
Alex_Combessie
Dataiker
Dataiker

Hi,

Can you clarify what is not working? Are you able to download the ZIP file?

If so, you need to uninstall the existing plugin, and install it again from the ZIP file by following the documentation I linked to in my previous post: https://doc.dataiku.com/dss/latest/plugins/installing.html#installing-from-a-zip-file

Best regards,

Alex

0 Kudos
BALA
Level 2
Author

Hi ,

Now downloaded the file manually but in running the model again not came the output successfully.PFA

 

in the Speechmacro they able see the models and sample.But I am not able to import that!

 

0 Kudos
BALA
Level 2
Author

Hi,  Give your time to discuss to explore in these plugin for 10mins Need your help.I created one project>created two folder>managed>speech/macro(where I add my audio file ml.wav in both the folder ) > and use the plugin to interlink and perform the run it giving the error instead of translation as text

0 Kudos
Alex_Combessie
Dataiker
Dataiker

Hi,

After investigation, I confirm that the libstdc++6 requirements also applies to the previous version of the plugin. Could you please try again with the 0.1 version?

The procedure to uninstall the previous version and re-install from the ZIP archive is the same as my previous article.

We will evaluate how to reduce the system requirements of this plugin in a future plugin release.

Best regards,

Alex

BALA
Level 2
Author

Hi,

 

Even Tried with other version of 5.1 and all available versions.Now come with this error attached.PFA.

0 Kudos
Alex_Combessie
Dataiker
Dataiker

Hi,

I am afraid screenshots are not sufficient to diagnose the issue. Could you please send us a job diagnosis by following this procedure?

If the resulting file is too large for mail (> 15 MB), you can use https://dl.dataiku.com to send it to us. Please don't forget to send the link that is generated when you upload the file.

Best regards,

Alex

0 Kudos
BALA
Level 2
Author

Hi Alex,

 

I uploaded my job diagnosis as in video format for better understanding! Please have a look in the Plik (dataiku.com) dashboard. the file in the name of after manual installation of plugin_Bala.zip and with existing plugin_Bala.mp4 .Please let me know if you got that

 

0 Kudos
Alex_Combessie
Dataiker
Dataiker

I am afraid I cannot use a video to diagnose the problem. Please send the job diagnosis ZIP archive.

0 Kudos
Alex_Combessie
Dataiker
Dataiker

To generate a job diagnosis, please follow the steps highlighted on this page (linked in my previous message): https://doc.dataiku.com/dss/latest/troubleshooting/problems/job-fails.html#getting-a-job-diagnosis

  • Go to the page of the affected job
  • Click on Actions > Download job diagnosis  (top right of your screen)
  • This will download the job diagnosis to your local machine

Please upload this job diagnosis to dl.dataiku.com  and please don't forget to send the link that is generated when you upload the file.

0 Kudos
BALA
Level 2
Author

 

 

 

 

Please find the attached Job Diagnosis and let me know how to fix the same.Thank you for supporting! attached JD  below

0 Kudos
Alex_Combessie
Dataiker
Dataiker

Hi,

Thanks. Reading the job diagnosis, it looks like the code-env of the plugin has not been updated.

Could you navigate to the Speech-to-Text plugin page and create a new code-env from this screen?

Screenshot 2020-12-02 at 10.49.15.png

Click on "Create a new one".

Then, please try to run the same recipe again. If it fails, please send us the new job diagnosis.

Best regards,

Alex

0 Kudos
BALA
Level 2
Author

Hi Alex,

I am updating the code env and send you the JD again

 

0 Kudos
BALA
Level 2
Author

Hi Please find the updated or created new code env work and corresponding JD is here attached

0 Kudos
Alex_Combessie
Dataiker
Dataiker

Hi,

Reading the job diagnosis, it looks like that the 0.1 version of the plugin has not been installed.

Could you please make sure again that you have followed all the steps from my previous messages, by replaying the following procedure:

0. Verify that your DSS version is 8.0.X (? > About)

Screenshot 2020-12-03 at 08.42.03.png

1. Uninstall your current Speech-to-Text plugin

Screenshot 2020-12-03 at 08.35.16.png

2. Reinstall the plugin using this ZIP archive: https://update.dataiku.com/dss/8.0/plugins/speech-to-text-cpu/0.1.0/dss-plugin-speech-to-text-cpu-0....

Screenshot 2020-12-03 at 08.38.20.png

3. Create a new code-env for the plugin after installation

Screenshot 2020-12-03 at 08.40.00.png

4. Re-run your test project to validate the correct behavior of the plugin

Please re-run the "Download DeepSpeech model" macro before re-running the "Speech to text" recipe.

---

If you still get a failure after following all of these steps, I would ask you to provide all the following elements:

- The failed job diagnosis: https://doc.dataiku.com/dss/latest/troubleshooting/problems/job-fails.html#getting-a-job-diagnosis

Screenshot 2020-12-03 at 09.15.02.png

- The code-env creation diagnosis: 

Screenshot 2020-12-03 at 09.16.18.png

- An export of the test project you are using:

Screenshot 2020-12-03 at 09.17.42.png

Best regards,

Alex

 

0 Kudos
BALA
Level 2
Author

Not able to downlaod manually

 

 

Note that in that case, you will need to install the plugin manually from the ZIP archive: https://doc.dataiku.com/dss/latest/plugins/installing.html#installing-from-a-zip-file. You will no longer be able to benefit from the latest updates from the Store.

0 Kudos
BALA
Level 2
Author

Hi ,

Please let me know step by step procedure can explore sentimental analysis -> speech to text plugin with free trial .

Please share if you have any video/document or any demo 

 

0 Kudos
A banner prompting to get Dataiku DSS